Myles Braithwaite

It’s Python, Not Python 2, Not Python 3!

This whole debate makes newcomers to run away, it's confusing, nonsense and more importantly a bubble, fairy dust, it doesn't exist and it shouldn't be there, It's only the Python and that's it.

If you're on the older version (Python 2 as you say), you're a decade behind, you should have upgraded at 2008.

You wanna say Unicode or print statement or 2to3, or tiny stuff that are deprecated? If you forget to upgrade you hit those too, no surprise.

Read this next
You might enjoy